Шаблоны кода 1С


Добавить новый Назад

Вызов формы подбора в управляемой форме

Вызов формы подбора в управляемой форме

П 			= Новый Структура;
	ФормаВыбора = ПолучитьФорму("Документ.расходТовара.Форма.подбор",П,этаФорма);
	ФормаВыбора.Открыть();
Добавить комментарий

Вызов шаблона в управляемой форме

Вызов шаблона в управляемой форме

схемаКомпоновкиДанных 		= РеквизитФормыВЗначение("Объект").ПолучитьМакет("имяОтчета");
Добавить комментарий

ДобавитьИтераторТаблице

Добавляет колонку в таблицу значений. Заполняет колонку переданным значением

// Добавляет колонку в таблицу значений. Заполняет колонку переданным значением
//
// Параметры:
//  Таблица           - ТаблицаЗначений - таблица значений для добавления колонки
//  ЗначениеИтератора - Произвольный - значение, которым будет заполнено новое поле таблицы
//  ИмяПоляИтератора  - Строка - имя добавляемого поля
// 
Процедура ДобавитьИтераторТаблице(Таблица, ЗначениеИтератора, ИмяПоляИтератора) Экспорт
	
	Таблица.Колонки.Добавить(ИмяПоляИтератора);
	
	Таблица.ЗаполнитьЗначения(ЗначениеИтератора, ИмяПоляИтератора);
	
КонецПроцедуры
Добавить комментарий

ПолучитьДатуФайла

Функция определяет дату последней модификации существующего файла на диске

// Функция определяет дату последней модификации существующего файла на диске
// Параметры
//  ИмяФайла  – Строка, содержащая полный путь к файла на диске.
//
// Возвращаемое значение:
//   Дата – Дата последней модификации файла
//
Функция ПолучитьДатуФайла(Знач ИмяФайла) Экспорт
	
	Файл = Новый Файл(ИмяФайла);
	Возврат Файл.ПолучитьВремяИзменения();
	 
КонецФункции
Добавить комментарий

ПолучитьИмяФайла

Составляет полное имя файла из имени каталога и имени файла

// Составляет полное имя файла из имени каталога и имени файла.
//
// Параметры
//  ИмяКаталога  – Строка, содержащая путь к каталогу файла на диске.
//  ИмяФайла     – Строка, содержащая имя файла, без имени каталога.
//
// Возвращаемое значение:
//   Строка – полное имя файла с учетом каталога.
//
Функция ПолучитьИмяФайла(ИмяКаталога, ИмяФайла) Экспорт

	Если Не ПустаяСтрока(ИмяФайла) Тогда
		
		Возврат ИмяКаталога   ?(Прав(ИмяКаталога, 1) = "\", "", "\")   ИмяФайла;	
		
	Иначе
		
		Возврат ИмяКаталога;
		
	КонецЕсли;

КонецФункции // ПолучитьИмяФайла()
Добавить комментарий

TurboConf

Удобный поиск шаблонов кода

прямо в Конфигураторе

Узнать подробнее