Диалоги вопроса и предупреждения пользователю в TurboConf SDK

Добавил: bolsun, 25 декабря 2018 10:54, обновлено: 10 января 2019 10:54

Раздел: Обсуждение TurboConf

TurboConf SDK Скрипты OneScript Обучение


В TurboConf 5.6 появились диалоги ВопросПользователю и ПредупреждениеПользователю

Демонстрация работы

Image https://turboconf.ru/Content/Files/31C694EEA2260A37464FB9F25FA7B436FB000A06/TurboConf56_SDK_Dialogs2.png

Пример скрипта

//@script_name DialogsSample
//@script_hotkey Control+Shift+OemTilde
//@retain_clipboard 0
//@enterprise_mode 0
//@hide_actions 0
//@global_mode 1
//@filter - Visual Studio Code
//@turbomenu 1
//@turbobutton 1

Перем ТурбоКонф;

Процедура ПродолжаемПослеПредупреждения(Результат, Параметры) Экспорт

	ТурбоКонф.ПоказатьПодсказку("Продолжаем скрипт...");
	
КонецПроцедуры

Процедура ОбработчикОтветаПользователя(Результат, Параметры) Экспорт
	
	Если Результат = КодВозвратаДиалога.Да Тогда
		Предупреждение = Новый ПредупреждениеПользователю();
		Предупреждение.Текст = "Пользователь выбрал Да. Вопрос задан " + Строка(Параметры);
		Предупреждение.Заголовок = "Ответ пользователя";
		Предупреждение.УстановитьОбработчик(ЭтотОбъект, "ПродолжаемПослеПредупреждения");
		Предупреждение.Показать();
	КонецЕсли;
	
КонецПроцедуры

ТурбоКонф = Новый ТурбоКонф;

ВопросПользователю = Новый ВопросПользователю(РежимДиалогаВопрос.ДаНетОтмена);

ВопросПользователю.Заголовок = "Мой заголовок"; //Необязательно
ВопросПользователю.Текст = "Показать ответ пользователя?";
ВопросПользователю.УстановитьОбработчик(ЭтотОбъект, "ОбработчикОтветаПользователя");
ВопросПользователю.Параметры = ТекущаяДата(); //Необязательно

ВопросПользователю.Показать();

К списку тем

Комментарии

Сергей
10 января 2019 10:38: #1

Есть ли возможность показать такое же окно как при вставке из мультибуфера, только со своим текстом? Чтобы не диалоговое с кнопками, а похожее на подсказку.


bolsun
10 января 2019 10:54: #2

Да, можно. Форма выбора значения

https://turboconf.ru/Forum/Details/1509

Здесь можно посмотреть все темы по SDK

https://turboconf.ru/Forum/Details/1529

TurboConf

Расширение возможностей

Конфигуратора 1С

Скачать

Бесплатный пробный период 14 дней