Часто не видит процедуры\функции в своем модуле и общих

Добавил: Михаэль, 26 декабря 2018 09:19, обновлено: 27 декабря 2018 13:43

Раздел: Баги

Скачать

В контекстной подсказке часто не указываются процедуры и функции, которые в том же модуле. Такая же проблема с функциями и процедурами в "Общие модули" Инфо о системе: 1CVersion: 8.3.9.1850 ProductVersion: 5.6.6926.35881 UAC: True CompatibilityMode: True SystemInfo: Microsoft Windows NT 6.1.7601 Service Pack 1 x64 CPU: 4 TurboConf Settings: { "CompatibilityMode": false, "DontShowUacForm": false, "UseWindowsTheme": false, "UseWaitHack": true, "DelayMultipler": 10, "AllowEnterprise": true, "InsertCarriageReturns": false, "ClearMessageWindowBeforeCheck": true, "FormatAllText": true, "Windows8Mode": true, "ParametersWindowPosX": -1, "ParametersWindowPosY": -1, "PinMessageWindow": false, "AgreementShown": true, "InsertSpaces": true, "CheckForUpdates": false, "InspectParameters": true, "InspectVars": true, "InspectFunctions": true, "InspectAssignments": true, "InspectReturns": true, "GoToDefinition": true, "EditDataType": true, "ReplaceSystemMenu": false, "AddAlignSpaces": true, "RemoveExtraLineBreaks": true, "InsertIBNameBefore": false, "T9AutoShowAfterPeriod": true, "T9AllowSwitch": true, "SetForegroundWindowDelay": 50, "EmbeddedInspector": false, "AutoCompleteOnEnter": false, "TurboMenuOnCtrlRMB": false, "T9Enabled": false, "JumpToAutoSettings": true, "T9StyleVS": false, "BetaEnabled": false, "ShowStartForm": true, "UpgradeRequired": false, "ShowUpdateForm": true, "CloseSearchWindowAfterJump": true, "AlignCommas": true, "T9AlwaysShowOnCtrlSpace": true, "T9PasteTextOnEscape": true, "V8DataVersion": "8.3.5.1383", "CheckForDataUpdates": true, "ShiftT9Window": false, "ShowT9OnCtrlShiftSpace": true, "RemapDefaultParametersInfoOnCtrlP": true, "Plugins": "{\"OpenHelpForm\":{\"PluginName\":\"Помощь\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":49,\"Enabled\":false,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"OpenForumPage\":{\"PluginName\":\"Форум\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":0,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"ExtractMethod\":{\"PluginName\":\"Извлечь метод\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":77,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"ProcedureAndFuctions\":{\"PluginName\":\"Процедуры и функции модуля\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":75,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"Surround\":{\"PluginName\":\"Окружить\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":68,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"Rename\":{\"PluginName\":\"Переименовать\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":82,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"JumpToObject\":{\"PluginName\":\"Прыгнуть к объекту конфигурации\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":74,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":false,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"FindTemplate\":{\"PluginName\":\"Найти шаблон\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":66,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"CodeInspector\":{\"PluginName\":\"Инспектировать\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":73,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":false,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"ShowParameters\":{\"PluginName\":\"Информация о параметрах\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":80,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":false,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"FormatBlock\":{\"PluginName\":\"Выровнять блок текста\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":187,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"AlignCommas\":{\"PluginName\":\"Выровнять блок текста по запятым\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":188,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"CloseBrackets\":{\"PluginName\":\"Закрыть скобки\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":48,\"Enabled\":false,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"ShowInfoBaseName\":{\"PluginName\":\"Показать имя информационной базе в заголовке\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":123,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":false,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"TurboMenu\":{\"PluginName\":\"ТурбоМеню\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":192,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":false,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"OpenStore\":{\"PluginName\":\"Открыть сайт TurboConf.ru\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":0,\"Enabled\":true,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"TurboConf\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null},\"Netlenka\":{\"PluginName\":\"Защитить модуль\",\"HotKey\":null,\"Ctrl\":true,\"KeyCode\":85,\"Enabled\":false,\"IsCorePlugin\":true,\"AllowEnterprise\":true,\"Developer\":\"Netlenka1c.ru\",\"AppId\":\"\",\"Id\":\"\",\"FileName\":null}}", "MultiClipboardEnabled": true, "OpenHistory": "", "OpenFilesHook": false, "OpenFileConfirmation": false, "LastOpenPath": "", "T9IncludeStrings": true, "NetlenkaFormatResult": false, "NetlenkaEncryptStrings": true, "NetlenkaByteCode": false, "NetlenkaControlFlow": false, "AutoTitleEnabled": true, "CheckForBetaVersions": true, "SaveWindowsHistory": true, "MaxWindowsHistorySize": 100, "MaxJumpToHistorySize": 100, "OneTrackerEnabled": false, "OneTrackerIdleTime": 10, "OneTrackerSaveInterval": 30, "OneTrackerAddIBSuffix": true, "OneTrackerSaveToFolder": 0, "DebugMode": false, "ToDoEnabled": false, "AutoContextMenu": false, "JumpToIncludeMatches": true, "PinHintWindow": false, "HintWindowPosX": 1270, "HintWindowPosY": 877, "ShowStartWizard": false, "TurboIconEnabled": true, "JumpToAllObjects": true, "TurboMenuEnabled": true, "AutoContextMenuDelay": 100, "JumpToPasteSelectedText": false, "ShowVersionChanges": true, "AutoContextMenuEnterpiseMode": false, "T9AlwaysAssists": false, "T9AssistEnabled": true, "T9AllowFields": true, "AutoFilterSyntaxHelper": false, "CheckForPreviewVersions": false, "ScriptsSettings": "", "WebClientWidth": 1228, "WebClientHeight": 805, "WebClientLeft": 375, "WebClientTop": 131, "T9AssistSmartFieldsEnabled": true, "T9AssistGetMenuItems": false, "T9HybridModeEnabled": true, "SettingsKey": "", "IsSynchronized": true }

Файл


Скачать К списку тем

Комментарии

Михаэль
26 декабря 2018 09:20: #1

Поясняющая картинка в приложении


bolsun
26 декабря 2018 09:34: #2

Можете прислать фрагмент кода?


bolsun
26 декабря 2018 10:00: #3

А лучше весь модуль.


Михаэль
26 декабря 2018 10:26: #4

Боюсь, что весь модуль не могу, по понятным причинам. Фрагмент, конечно. Процедура ДоступностьЭлементов(мЭлементов, ЗначениеЭлементов, ДоступностьЭлементов = Истина) Для Каждого ЭлементФормы Из мЭлементов Цикл ЭлементФормы.Значение = ЗначениеЭлементов; ЭлементФормы.Доступность = ДоступностьЭлементов; КонецЦикла; КонецПроцедуры Процедура ДоступностьЭлементовПроизводитель(Элемент) мЭлементыФормыПроизводитель = Новый Массив; мЭлементыФормыПроизводитель.Добавить(ЭлементыФормы.ПроизводительНасосовWilo); мЭлементыФормыПроизводитель.Добавить(ЭлементыФормы.ПроизводительНасосовGrundfos); мЭлементыФормыПроизводитель.Добавить(ЭлементыФормы.ПроизводительНасосовАнтарус); мЭлементыФормыПроизводитель.Добавить(ЭлементыФормы.ПроизводительНасосовKVC); мЭлементыФормыПроизводитель.Добавить(ЭлементыФормы.ПроизводительНасосовЛюбой); //Если Не (ТипСтанции = "Antarus") Тогда // ДоступностьЭлементов(мЭлементыФормыПроизводитель, Ложь); //КонецЕсли; // //Если ТипСтанции = "Wilo" Тогда // ПроизводительНасосовWilo = Истина; //ИначеЕсли ТипСтанции = "Grundfos" Тогда // ПроизводительНасосовGrundfos = Истина; //ИначеЕсли ТипСтанции = "Antarus" Тогда // Если ТипЗнч(Элемент) = Тип("Переключатель") Тогда // ДоступностьЭлементов(мЭлементыФормыПроизводитель, Ложь); // КонецЕсли; // //ПроизводительНасосовАнтарус = Истина; //КонецЕсли; //ДоступностьЭ; КонецПроцедуры


bolsun
26 декабря 2018 11:35: #5

Спасибо! Баг, подтверждаю. Исправлю.


Михаэль
26 декабря 2018 12:48: #6

Отлично! Самое главное, это чтобы воспроизводилось!)


bolsun
26 декабря 2018 15:29: #7

Исправлено в текущей версии.


Михаэль
27 декабря 2018 08:26: #8

Текущая - это которая сейчас последняя для скачивания? Или которая сейчас разрабатывается?


bolsun
27 декабря 2018 08:34: #9

Да, непонятно написал :) В версии 5.6.6934.30541, которая вышла вчера.


Михаэль
27 декабря 2018 09:45: #10

А у меня сейчас 5.6.6926.35881 и при нажатии на "проверить обновления" - "Вы используете самую последнюю версию". 5.6.6934.30541 - уже доступна для скачивания или нет?


bolsun
27 декабря 2018 10:11: #11

Она вышла на тестовом канале, для обновления установите флаг "Получать тестовые версии для ознакомления", на вкладке "Для разработчиков"


Михаэль
27 декабря 2018 10:38: #12

С текущего модуля стал нормально тянуть вроде. Но вот с общего так и не тянет. А оттуда постоянно что-то приходится использовать. Посмотрите, пожалуйста.

Image https://turboconf.ru/Content/Files/4B329DBDA38459D944043E59AEC07F1B24B719CF/%D0%9D%D0%B5%20%D1%82%D1%8F%D0%BD%D0%B5%D1%82.png

bolsun
27 декабря 2018 11:17: #13

В таком режиме как у Вас (всегда показывать T9) подсказка пока может получать методы только из текущего модуля. Почему бы Вам не использовать новый гибридный режим? Там будут все методы и многое другое?


Михаэль
27 декабря 2018 12:03: #14

А как его активировать? Отключить галку всегда Т9? Или что-то еще?


bolsun
27 декабря 2018 12:11: #15

Я как-раз сейчас переделываю окно настроек. Гибридный режим уже включен в тестовых версиях. В Вашем случае нужно отключить флаги "Всегда показывать T9 по Ctrl+Пробел" и "Показывать подсказку T9 по Ctrl+Shift+Пробел, а подсказку о параметрах по Ctrl+P"


Михаэль
27 декабря 2018 13:43: #16

Ага, спасибо. Кажется стало здорово!


TurboConf

Расширение возможностей

Конфигуратора 1С

Скачать

Бесплатный пробный период 14 дней