Перейти к началу/концу метода

Добавил: bolsun, 22 апреля 2019 10:01, обновлено: 22 апреля 2019 10:13

Раздел: Обсуждение TurboConf

TurboConf SDK Скрипты Помощь

Скачать

Скрипт выполняет переход к началу/концу текущей процедуры или функции

Перейти к началу метода Ctrl+Alt+[

Перейти к концу метода Ctrl+Alt+]

Image https://turboconf.ru/Content/Files/31C694EEA2260A37464FB9F25FA7B436FB000A06/GoToMethodStartEnd.png

Скрипт войдет в следующую поставку TurboConf, а пока можно скачать его здесь.

Поместите скрипт в папку ./scripts и нажмите Ctrl+Shift+R в конфигураторе для перезагрузки скриптов

//@script_name GoToMethodStartEnd
//@script_display_name Перейти к началу/концу текущего метода
//@script_description Скрипт выполняет переход к началу/концу текущей процедуры/функции
//@script_author m.bolsun
//@script_developer_url https://turboconf.ru
//@script_hotkey Control+Alt+OemOpenBrackets ПерейтиКНачалуМетода
//@script_hotkey Control+Alt+OemCloseBrackets ПерейтиККонцуМетода
//@retain_clipboard 0
//@enterprise_mode 0
//@hide_actions 0

Процедура ПерейтиКНачалуМетода()

	Перейти(Истина);
	
КонецПроцедуры

Процедура ПерейтиККонцуМетода()
	
	Перейти(Ложь);
	
КонецПроцедуры

Процедура Перейти(КНачалуМетода)
	
	ТК = Новый ТурбоКонф; 
	
	ТК.Key(Keys.Home);
	
	ТК.ControlAltKey(Keys.P);
	
	Окно = ТК.ЖдатьОкно("Процедуры и функции", 2000, Истина, Ложь);
	
	ТК.Key(Keys.Enter);

	Если КНачалуМетода Тогда
	
		Возврат;
		
	КонецЕсли;

	ТК.ЖдатьЗакрытияОкна(Окно, "Процедуры и функции", 1000);

	ТК.ControlKey(Keys.OemCloseBrackets);

КонецПроцедуры

Файл

Сайт разработчика: https://turboconf.ru

Страница разработки в соцсетях: https://vk.com/turboconf


Скачать К списку тем

Комментарии

TurboConf

Расширение возможностей

Конфигуратора 1С

Скачать

Бесплатный пробный период 14 дней