Поиск в тексте модуля с переходом

Добавил: prog1c, 05 сентября 2019 12:02, обновлено: 18 сентября 2019 08:47

Раздел: Предложения и идеи

Скрипты


Найти в тексте модуля ниже текущей позиции фрагмент КонецЕсли (или КонецЦикла) и прокрутить окно + переместить курсор в эту строчку. Штатно в КонецЕсли можно перейти нажав Ctrl+] находясь куросром на начальной конструкции Если или Иначе, а хочется - из любого места тела конструкции. Сложность реализации так же заключается в том, что если искать поиском КонецЕсли, то будет найден ближайший фрагмент, который может быть вложенной/внешней конструкцией другого уровня.


К списку тем

Комментарии

bolsun
17 сентября 2019 16:09: #1

bolsun переместил тему в раздел Предложения и идеи


bolsun
17 сентября 2019 16:10: #2

Пока такой функции нет, перенес в Предложения.


miha
17 сентября 2019 19:04: #3

Желательно четыре скрипта: - На следующую конструкцию "ИначеЕсли" / "Иначе" / "КонецЕсли" - Сразу на "КонецЕсли" - На предыдущую конструкцию "ИначеЕсли" / "Если" - Сразу на "Если".


TurboConf

Расширение возможностей

Конфигуратора 1С

Скачать

Бесплатный пробный период 14 дней