Как реализовать поиск в тексте модуля с переходом

Добавил: prog1c, 05 сентября 2019 12:02, обновлено: 05 сентября 2019 12:43

Раздел: Вопросы и ответы

Скрипты


Как реализовать скрипт: Найти в тексте модуля ниже текущей позиции фрагмент КонецЕсли (или КонецЦикла) и прокрутить окно + переместить курсор в эту строчку? Штатно в КонецЕсли можно перейти нажав Ctrl+] находясь куросром на начальной конструкции Если или Иначе, а хочется - из любого места тела конструкции. Сложность реализации так же заключается в том, что если искать поиском КонецЕсли, то будет найден ближайший фрагмент, который может быть вложенной/внешней конструкцией другого уровня.


К списку тем

Комментарии

TurboConf

Расширение возможностей

Конфигуратора 1С

Скачать

Бесплатный пробный период 14 дней