Объявить тип переменной

Добавил: miha, 12 сентября 2019 10:11, обновлено: 27 сентября 2019 18:11

Раздел: Предложения


Основная база у меня работает на 8.2.19 тексты я пишу для использования плюшек от ТурбоКонфа в 8.3.12. Поэтому конструкция: #Область TurboConf_ОбъявлениеТипов Если Ложь Тогда Параметры = Новый ; КонецЕсли; #КонецОбласти При проверке выдает ошибку. Команда препроцессора не известна. Я для себя пользуюсь другим шаблоном: // типизирование переменных без вреда для исполняемого кода #Если Сервер И Не Сервер Тогда Параметры = Новый Структура; #КонецЕсли который нормально отрабатывает на 8.2 Хотелось бы объявление типа переменной обрамлять так, как это делается у меня. Поэтому и прошу перенести в Скрипты.


К списку тем

Комментарии

miha
18 сентября 2019 15:30: #1

Как вариант сейчас срабатывает такая конструкция: #Если Сервер И Не Сервер Тогда // #Область TurboConf_ОбъявлениеТипов тзМагазины = Новый ТаблицаЗначений; Параметры = Новый Структура; #КонецЕсли // #КонецОбласти


bolsun
18 сентября 2019 15:44: #2

(1) miha, вообще 8.2 не поддерживается :) но попробую добавить, такого вида будет конструкция: //#Область TurboConf_ОбъявлениеТипов Если Ложь Тогда Спр = Справочники.Справочник1.СоздатьЭлемент(); КонецЕсли; Если Ложь Тогда Таб = Новый ТаблицаЗначений; КонецЕсли; //#КонецОбласти


bolsun
18 сентября 2019 15:45: #3

bolsun изменил статус на Принятые предложения


miha
19 сентября 2019 07:03: #4

(3) bolsun, Зачем делать в каждой строчке Если Ложь Тогда Когда можно на весь блок написать #Если Сервер И Не Сервер Тогда Компилироваться и выполняться будет быстрее + более аккуратно выглядит


bolsun
27 сентября 2019 18:11: #5

В версии 5.9.7195.24038 внес изменения, чтобы работало в 8.2 Пока без настраиваемых шаблонов, но хотя бы работает.


bolsun
21 апреля 2020 14:04: #6

bolsun изменил статус на Завершено


TurboConf

Расширение возможностей

Конфигуратора 1С

Скачать

Бесплатный пробный период 14 дней