Установить препроцессор

Добавил: Phoenix, 21 января 2020 22:36, обновлено: 16 февраля 2021 15:52

Раздел: Скрипты пользователей

Скрипты

Скачать

Image https://turboconf.ru/Content/Files/AA72F36E109C374BCDB44FA18593410B24CE1F4D/TurboConf-Preprocessor.png


//@script_name УстановитьПрепроцессор
//@script_display_name  Установить препроцессор
//@script_description Устанавливает препроцессор
//@script_author sushakov
//@script_developer_url PhoenixUSA@yandex.ru
//@script_hotkey Control+D7 УстановитьПрепроцессорМетода
//@script_hotkey Control+Shift+D7 УстановитьАннотациюРасширения
//@retain_clipboard 1
//@hide_actions 0

#Область ПрограммныйИнтерфейс

Процедура УстановитьПрепроцессорМетода() Экспорт

	Пункты = Новый Соответствие;
	Пункты.Вставить("&НаСервере", "&НаСервере");
	Пункты.Вставить("&НаСервереБезКонтекста", "&НаСервереБезКонтекста");
	Пункты.Вставить("&НаКлиенте", "&НаКлиенте");
	
	Форма = Новый ФормаВыбораЗначения;
	Форма.Заголовок            = "Препроцессор";
	Форма.Данные               = Пункты;
	Форма.АвтоматическийРазмер = Истина;
	Форма.УстановитьДействие(ЭтотОбъект,  "УстановитьПрепроцессор");
	Форма.Показать();	

КонецПроцедуры

Процедура УстановитьАннотациюРасширения() Экспорт
	
	Элементы = Новый Массив;
	Элементы.Добавить(НовыйПункт("&&Вместо (1)", "1 Вместо", "&Вместо"));
	Элементы.Добавить(НовыйПункт("&&Перед (2)", "2 Перед", "&Перед"));
	Элементы.Добавить(НовыйПункт("&&После (3)", "3 После", "&После"));
	Элементы.Добавить(НовыйПункт("&&ИзменениеИКонтроль (4)", "4 ИзменениеИКонтроль", "&ИзменениеИКонтроль"));

	Элементы.Добавить(НовыйПункт("#Удалить (5)", "5 Удалить", "#Удалить"));
	Элементы.Добавить(НовыйПункт("#КонецУдалить (6)", "6 КонецУдалить", "#КонецУдалить"));

	Элементы.Добавить(НовыйПункт("#Вставить (7)", "7 Вставить", "#Вставить"));
	Элементы.Добавить(НовыйПункт("#КонецВставить (8)", "8 КонецВставить", "#КонецВставить"));

	Форма = Новый ФормаСписка;
	Форма.Заголовок            = "Препроцессор";
	Форма.Данные               = Элементы;
	Форма.УстановитьДействие(ЭтотОбъект,  "УстановитьАннотацию");
	Форма.Показать();

КонецПроцедуры

#КонецОбласти

#Область ОбработчикиСобытий

Процедура УстановитьПрепроцессор(Значение, Отказ) Экспорт

	УстановитьВыбранноеЗначение(Значение, Отказ);

КонецПроцедуры

Процедура УстановитьАннотацию(Значение, Отказ) Экспорт

	УстановитьВыбранноеЗначение(Значение, Отказ);

КонецПроцедуры

#КонецОбласти

#Область СлужебныеПроцедурыИФункции

Функция НовыйПункт(Представление, Фильтр = Неопределено, Значение = Неопределено)
	
	Фильтр   = ?(Фильтр = Неопределено, Представление, Фильтр);
	Значение = ?(Значение = Неопределено, Представление, Значение);

	ЭлементСписка = Новый Соответствие();
	ЭлементСписка.Вставить("Представление", Представление);
	ЭлементСписка.Вставить("Фильтр", Фильтр);
	ЭлементСписка.Вставить("Значение", Значение);

	Возврат ЭлементСписка;

КонецФункции

Процедура УстановитьВыбранноеЗначение(Значение, Отказ)

	Если ПустаяСтрока(Значение) Тогда
		Возврат;
	КонецЕсли;

	ТК = Новый ТурбоКонф;
	ТК.ВставитьТекст(Значение);	
	
КонецПроцедуры

#КонецОбласти

Файл


Скачать К списку тем

Комментарии

bolsun
16 февраля 2021 15:45: #1

bolsun переместил тему в раздел Скрипты пользователей


TurboConf

Расширение возможностей

Конфигуратора 1С

Скачать

Бесплатный пробный период 14 дней