Новый скрипт: Преобразовать строку в имя

Добавил: Phoenix, 21 января 2020 23:20, обновлено: 22 января 2020 20:11

Раздел: Предложения и идеи

Скрипты

Скачать

Преобразовать строку в имя по правилу CamelCase: Мое название переменной БО -> МоеНазваниеПеременнойБО



//@script_name ConvertToName
//@script_display_name Преобразовать строку в имя
//@script_description Преобразовать строку в имя по правилу CamelCase:  Мое название переменной БО -> МоеНазваниеПеременнойБО
//@script_author sushakov
//@script_developer_url PhoenixUSA@yandex.ru
//@script_hotkey Alt+Shift+N ПреобразоватьСтрокуВИмя
//@retain_clipboard 1
//@hide_actions 0

#Область ПрограммныйИнтерфейс

Процедура ПреобразоватьСтрокуВИмя() Экспорт
	
	ТурбоКонф = Новый ТурбоКонф;
	
	ПозицияКурсора  = 0;
	ВыделенныйТекст = "";
	
	ТурбоКонф.ПолучитьТекстМодуля(ВыделенныйТекст, ПозицияКурсора);

	ДопустимыеСимволы = "йцукенгшщзхъфывапролджэячсмитьбю"
		+ "qwertyuiopasdfghjklzxcvbnm"
		+ " _1234567890";
	
	ДопустимыйТекст = "";
	ДлинаСтроки = СтрДлина(ВыделенныйТекст);
	Для А = 1 По ДлинаСтроки Цикл
		
		СимволИзСтроки = Сред(ВыделенныйТекст, А, 1);
		Если СтрНайти(ДопустимыеСимволы, НРег(СимволИзСтроки)) > 0 Тогда
			ДопустимыйТекст = ДопустимыйТекст + СимволИзСтроки;
		КонецЕсли;
		
	КонецЦикла;
	
	МассивСлов = СтрРазделить(ДопустимыйТекст, " ", Ложь);
	
	НовыйТекст = "";
	Для каждого Слово Из МассивСлов Цикл
		НовыйТекст = НовыйТекст + (ВРег(Лев(Слово, 1)) + Сред(Слово, 2));
	КонецЦикла;

	// Без этой строки дублирует текст, если он до знака равно
	ТурбоКонф.Key(Keys.Delete);
	
	ТурбоКонф.ВставитьТекст(НовыйТекст);
	
КонецПроцедуры

#КонецОбласти

Файл


Скачать К списку тем

Комментарии

Phoenix
22 января 2020 20:09: #1
Image https://turboconf.ru/Content/Files/AA72F36E109C374BCDB44FA18593410B24CE1F4D/TurboConf-ConvertToName.png

Phoenix
22 января 2020 20:09: #2
Image https://turboconf.ru/Content/Files/AA72F36E109C374BCDB44FA18593410B24CE1F4D/ConvertToName.os

TurboConf

Расширение возможностей

Конфигуратора 1С

Скачать

Бесплатный пробный период 14 дней