8.3.19 перестал работать скрипт "Процедура<->Функция"

tormozit Закрыто

Турбоконф 5.15.7629.24166 Платформа 8.3.19


// 
//
// Параметры:
//    –  – 
//                 ;
//    –  – 
//                 .
//
Процедура УстановитьТекст(Текст)

	ТекущееПоле = ЭлементыФормы[мТекущаяСтраница.Имя];
	ВыделитьВсе = ПараметрВыделитьВсе;
	Если ТипЗнч(ТекущееПоле) = Тип("ПолеВвода") Тогда
		ТекущееПоле.Значение = Текст;
		ВыделитьВсе = Истина;
	ИначеЕсли ТекущееПоле = ЭлементыФормы.JSON Тогда
		Если мРедакторJSON = Неопределено Тогда
			Возврат;
		КонецЕсли; 
		мРедакторJSON.setText(Текст);
	Иначе
		ТекущееПоле.УстановитьТекст(Текст);
	КонецЕсли; 
	Если ВыделитьВсе И СтрДлина(Текст) > 0 Тогда
		ТекущееПоле.УстановитьГраницыВыделения(1, СтрДлина(Текст) + 1);
	КонецЕсли; 

КонецПроцедуры
Image https://turboconf.ru/Content/Files/1165DFE919CB05373C26DFFD93BA26DF9DD382C5/Clip_197003.png

Комментарии

bolsun
#1, 27 января 2021 13:56

bolsun изменил статус на Завершено


Для вставки изображения или файла, перетащите его в поле редактора или вставьте файл из буфера