ИР Адаптер. Подсказка не видит методы (слова) текущего модуля если метод (слово) находится внутри свернутой области.

C6EEAF402E Закрыто

[20244021 13-40-Ссылка скрыта

Комментарии

tormozit
#1, 21 марта 2024 09:46

Нужны

  1. картинка окна подсказки и окружающего модуля
  2. текст модуля

tormozit изменил статус на Открыто


C6EEAF402E
#2, 21 марта 2024 10:26

картинка окна:

текст модуля:

#Область А1


&НаКлиенте
Процедура ПриОткрытии(Отказ)
	//Вставить содержимое обработчика
	//ЗаполнитьТабДок();
КонецПроцедуры


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	//Вставить содержимое обработчика
КонецПроцедуры


Процедура ЗаполнитьТабДок()    
	Реквизит1.Очистить();
	Макет = Документы.Документ4.ПолучитьМакет("Макет");
	Область = Макет.ПолучитьОбласть("Заголовок");
	Реквизит1.Вывести(Область);
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьТабДокНаСервере()
	ЗаполнитьТабДок();
КонецПроцедуры

&НаКлиенте
Процедура ЗаполнитьТабДок1(Команда)
	ЗаполнитьТабДокНаСервере();
КонецПроцедуры

&НаСервере
Процедура СохранитьТабДокНаСервере()
	Об = РеквизитФормыВЗначение("Объект");
	ХЗ = Новый ХранилищеЗначения(Реквизит1);
	Об.Реквизит1 = ХЗ;  
	Об.Записать();
	//Записать();
	//ЗначениеВРеквизитФормы(Об, "Объект");
КонецПроцедуры

&НаКлиенте
Процедура СохранитьТабДок(Команда)
	СохранитьТабДокНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗагрузитьТабДокНаСервере()
	Об = РеквизитФормыВЗначение("Объект");
	А = Об.Реквизит1.Получить();
	Реквизит1 = А;
КонецПроцедуры

&НаКлиенте
Процедура ЗагрузитьТабДок(Команда)
	ЗагрузитьТабДокНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
	//ТекущийОбъект.Реквизит1 = Новый ХранилищеЗначения(Реквизит1);
КонецПроцедуры

#КонецОбласти

Процедура А2()
	сохранить
КонецПроцедуры


C6EEAF402E
#3, 21 марта 2024 12:35

не важно, область не область - все равно не видит.


C6EEAF402E
#4, 21 марта 2024 12:38

вот для тебя еще видео сделал:
Video_2024-03-21_163720.mp4


C6EEAF402E
#5, 21 марта 2024 12:42

и выгрузку базы:
https://disk.yandex.com/d/BPk896VecGDqBg


tormozit
#6, 21 марта 2024 19:15

Ошибку воспроизвел https://www.hostedredmine.com/issues/982556


tormozit
#7, 24 марта 2024 23:11

Исправлено в ИР 7.20


tormozit
#8, 01 апреля 2024 08:01

tormozit изменил статус на Закрыто


Для вставки изображения или файла, перетащите его в поле редактора или вставьте файл из буфера