Автоподключение к хранилищу лишь со второй попытки

Yasnovidyashii Закрыто Высокий

Что-то явно привнесенное последними обновлениями.
К одному и тому же хранилищу у меня подключены две базы — для разработки и рабочая. Еще 2-3 дня назад автоподключение работало в обеих базах исправно.
На сегодняшний момент в рабочей базе оно нормально отрабатывает только со второй попытки. Основное отличие с базой для разработки — в ней отключено использование базы ИР.
Нажатие на кнопку Пуск при первой (неудачной) попытке явно осуществляется ТурбоКонфом. И это происходит каждый раз.

[20241402 14-14-Ссылка скрыта

Video_2024-05-02_141406.mp4

Комментарии

bolsun
#1, 02 мая 2024 15:55

Есть предыдущая версия для проверки, на которой работало? Или прислать?


bolsun
#2, ред. 02 мая 2024 15:59

Я вот вижу, что срабатывает скрипт user_scripts\RDT.os ПриПодключенииКонфигуратора
Нужно попробовать отключить обработчики в скриптах, вкладка Разработчикам и проверить снова и прислать лог, если проблема сохранится.


bolsun
#3, 02 мая 2024 16:01

Этот флаг отключить

Вижу что в процессе происходит нажатие Ctrl+Esc, нужно разобраться кто его отправляет. Эта комбинация уводит фокус в кнопку Пуск.


bolsun
#4, 02 мая 2024 16:04

Нажатие происходит во время выполнения обработчика ПриПодключенииКонфигуратора скрипта ИР Адаптер


bolsun
#5, 02 мая 2024 16:05

bolsun переместил тему в раздел ИР Адаптер


bolsun
#6, 02 мая 2024 16:28

Проверил у себя, на предыдущей версии ИР Адаптера все работает нормально.
После обновления до 1.48:

  1. Зачем-то открываются настройки конфигуратора
  2. Вызывается меню Пуск
  3. Все это при запрещенных ИР для данной конфигурации.


tormozit
#7, 02 мая 2024 16:31

(6) bolsun, "Зачем-то" - в списке изменений к этой версии есть ответ


bolsun
#8, ред. 02 мая 2024 16:34

"Зачем-то" - в списке изменений к этой версии есть ответ

(7) tormozit, в описании я указал, что ИР для данной конфигурации отключены, также это видно на скриншоте. Поэтому в данном случае причина открытия настроек непонятна.


bolsun
#9, 02 мая 2024 16:37

при первой активации конфигуратора базы с отключенным адаптером теперь автоматически (при отсутствии модальных окон) будет включаться автовызов подсказки конфигуратора

Если ИР адаптер отключен для конфигурации, почему он выполняет какие-то действия, которые я не просил. Хотя бы просто уведомление показал.

Второе - модальное окно может возникнуть чуть позже активации конфигуратора, что мешает подключаться к хранилищу.


bolsun
#10, 02 мая 2024 16:39

А еще зачем он это делает, если раньше он не был никогда включен для этой базы и при первом же диалоге ИР отключается.
После этого происходит открытие настроек и вызов Пуск.


tormozit
#11, ред. 03 мая 2024 07:49

(6) bolsun, Про вызов меню "Пуск" мне сложно что то подсказать. Вот код скрипта

Функция УстановитьАвтоподсказкуКонфигуратора(ЛиВключить) Экспорт
	Если Не ТурбоКонф.НайтиЭлементПоИмени("Сервис", "кнопка") Тогда
		Возврат Ложь;
	КонецЕсли;
	ТурбоКонф.КликнутьПоЭлементу("Сервис", "кнопка", 0, Ложь);
	//ТурбоКонф.КликнутьПоЭлементу("Параметры...", "кнопка", 0, Ложь); // Почему то не работает, хотя в Мультиметка777238164 работает
	ТурбоКонф.Клавиша(Клавиши.Up);
	ТурбоКонф.Клавиша(Клавиши.Enter);
	ТурбоКонф.ЖдатьСменуАктивногоОкна(ТурбоКонф.ПолучитьАктивноеОкно(), 1000, Ложь);
	ТурбоКонф.Ждать(100);
	ТурбоКонф.КликнутьПоЭлементу("Модули", "элемент вкладки", 0, Ложь);
	ТурбоКонф.КликнутьПоЭлементу("Контекстная подсказка", "элемент вкладки", 0, Ложь);
	Если Не ТурбоКонф.УстановитьФокусНаЭлемент("Автоматическая подсказка при наборе "".""", "флажок") Тогда
		ТурбоКонф.КонтролКлавиша(Клавиши.Escape);
		Возврат Ложь;
	КонецЕсли; 
	Если ТурбоКонф.ПолучитьСостояниеФлажка() <> ЛиВключить Тогда
		ТурбоКонф.УстановитьСостояниеФлажка(ЛиВключить);
		ТурбоКонф.ПоказатьВсплывающееУведомление(НазваниеСкрипта(), "" + ?(ЛиВключить, "Включена", "Отключена") + " автоподсказка конфигуратора. Поэтому все модули свернуты.", 5000);
	КонецЕсли;
	ТурбоКонф.КонтролКлавиша(Клавиши.Enter);
	Возврат Истина;
КонецФункции

Самая ненадежная часть:

	ТурбоКонф.Клавиша(Клавиши.Up);
	ТурбоКонф.Клавиша(Клавиши.Enter);

Пришлось прибегнуть к ней, т.к . не смог заставить работать
ТурбоКонф.КликнутьПоЭлементу("Параметры...", "кнопка", 0, Ложь)


tormozit
#12, 02 мая 2024 18:54

(9) bolsun, "Если ИР адаптер отключен для конфигурации"
Такой возможности адаптер не предоставляет. Он предоставляет возможность минимизировать свою активность для конкретной базы и для этого задает пользователю вопрос "Разрешить приложение ИР для этой базы?". Т.е. гарантируется что к базе не будет подключения клиентским приложением.

"Хотя бы просто уведомление показал"
Уведомление показывается в случае, если считанное состояние флажка не соответствует нужному и потому скрипт меняет его состояние. В других случаях я пока решил не показывать уведомление, т.к. у меня эта функция работала относительно стабильно, в том числе и в базе с хранилищем с автоподключением.

Про модальное окно которое появляется параллельно с выполнением скрипта я теперь понял.


tormozit
#13, ред. 02 мая 2024 19:12

(10) bolsun, "зачем он это делает, если раньше он не был никогда включен для этой базы"
Основная проблема тут в том, что я оперирую настройкой конфигуратора, которая не хранится в разрезе баз. Она общая для всех баз. Поэтому ее нужно сбрасывать при подключении к конфигуратору базы, где разрешен ИР, и устанавливать при подключении к базам, где он запрещен. Иначе может случится что автоподсказка конфигуратора в новой подключенной базе будет отключена, т.к. перед этим пользователь работал в базе с подсказкой ИР и потому явно/неявно ее отключил.


bolsun
#14, 02 мая 2024 19:04

(11) tormozit, я тебе писал как-то что в обработчике ПриПодключенииКонфигуратора нужно избегать интерактивного взаимодействия, оно может привести к непредсказуемым последствиям. Типа таких как сейчас.


bolsun
#15, 02 мая 2024 19:22

(13) tormozit, если мы хотим выпустить релиз 6.1 быстрее, то предлагаю не вносить таких критических изменений перед релизом и так хватает внесенных изменений. И сразу не понятно сломалось что-то из-за правок в движке или из-за правок адаптера.


tormozit
#16, 02 мая 2024 19:50

Исправлено в адаптере 1.49


tormozit
#17, 02 мая 2024 19:55

(15) bolsun, хорошо


Yasnovidyashii
#18, 02 мая 2024 21:16

Yasnovidyashii изменил статус на Закрыто


Для вставки изображения или файла, перетащите его в поле редактора или вставьте файл из буфера