ИР Адаптеру опять не работает

R2D2 Открыто

ScriptEngine.Machine.ExternalSystemException: {Модуль C:\ROOT\ТурбоКонф_6.2\apps\8552\RDT.os / Ошибка в строке: 1799 / Внешнее исключение (System.Runtime.InteropServices.COMException): {ИнструментыРазработчикаTormozit Обработка.ирКлсПолеТекстаПрограммы.МодульОбъекта(12257)}: Значение не является значением объектного типа (Количество)}
Успешно = ПолеТекстаПрограммы.ЗаполнитьТаблицуСлов(ТаблицаТипов,, ЕстьЛучшееСлово, РазрешитьОткрытиеОкон, Ложь, Не ЛиАвтовызов, Истина);
---> System.Runtime.InteropServices.COMException: {ИнструментыРазработчикаTormozit Обработка.ирКлсПолеТекстаПрограммы.МодульОбъекта(12257)}: Значение не является значением объектного типа (Количество)
в ScriptEngine.Machine.Contexts.UnmanagedCOMWrapperContext.CallAsFunction(Int32 methodNumber, IValue[] arguments, IValue& retValue)
в ScriptEngine.Machine.MachineInstance.ResolveMethodFunc(Int32 arg)
в ScriptEngine.Machine.MachineInstance.MainCommandLoop()
--- Конец трассировки внутреннего стека исключений ---
в ScriptEngine.Machine.MachineInstance.MainCommandLoop()
в ScriptEngine.Machine.MachineInstance.ExecuteCode()
в ScriptEngine.Machine.MachineInstance.ExecuteMethod(IRunnable sdo, Int32 methodIndex, IValue[] arguments)
в ScriptEngine.Machine.Contexts.ScriptDrivenObject.CallAsFunction(Int32 methodNumber, IValue[] arguments, IValue& retValue)
в TurboConf.HostApplication.HostApplicationForm.ExecuteScript(Script script, Keys ctrl, Keys alt, Keys shift, ScreenForm statusForm, String entryPoint, ScriptOptions options, IVariable[] parameters)

[20245709 16-57-Ссылка скрыта

Комментарии

tormozit
#1, ред. 09 июля 2024 13:02

Прошу давать заявкам более осмысленные названия, чтобы в их списке было проще ориентироваться.
Нужен текст модуля с указанием позиции каретки и выполняемого действия.
tormozit изменил статус на Открыто


R2D2
#2, 09 июля 2024 13:13

&НаКлиенте
Функция НайтиЭлементКоллекции(ИскомыйЭлемент)
	Для Каждого Э0 Из ДеревоДолжностиФизЛица.ПолучитьЭлементы() Цикл
		Для Каждого Э1 Из Э0.ПолучитьЭлементы() Цикл
			Если Э1 = ИскомыйЭлемент Тогда
				
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
КонецФункции


R2D2
#3, 09 июля 2024 13:13


tormozit
#4, 09 июля 2024 14:43

Нужен текст модуля, а не метода. На твоей картинке видно, что модуль содержит и другие методы.


R2D2
#5, 09 июля 2024 21:53

остальное работает. Разберись с этим методом.


tormozit
#6, ред. 09 июля 2024 22:04

(5) R2D2, обязательно разберусь, когда ты предоставишь текст модуля. В текущем виде проблема не воспроизводится. Если не веришь, попробуй сам.


tormozit
#7, 14 июля 2024 23:46

Пробуй новую версию ИР. Возможно исправлено.


Для вставки изображения или файла, перетащите его в поле редактора или вставьте файл из буфера